Users running Chrome 48 and earlier now forced to upgrade, Sync no longer supported | #firefox | #chrome | #microsoftedge

Sometimes, users gravitate toward an older version of Chrome because it doesn’t feature all of the extra bells and whistles, which they may or may not be averse to, or perhaps they’re rocking older hardware that simply doesn’t support newer updates. For a long time this has been okay but unfortunately today Google announced that it is ceasing its support for Chrome Sync for browser versions 48 and earlier.

This means that if you’re one of the aforementioned types of Chrome users, you’ll now have to upgrade in order to keep using Google’s browser. Chrome Sync is Google’s cloud service for automatically pushing all of your history, passwords, bookmarks, and more between devices that you’re signed into with your Google Account. It provides a convenient way to jump between a desktop, a Chromebook, phone, or any other device and operating system without you feeling “uprooted” or alienated in your workflow. It works across Windows, macOS, Linux, Chrome OS, Android, and iOS.

Because Sync is being disabled entirely, I would consider getting your ducks in a row ahead of time. For some, this simply means hitting the update button. For others, it means going out and purchasing a new Chromebook, desktop Windows machine, or MacBook. I understand how frustrating that can be, especially in the midst of the global pandemic. Google previously gave notice that it was dropping Sync support for version 48 and earlier, but it really does just seem to sneak up on you, especially when it was originally announced

If you must upgrade your hardware, and you also happen to be interested in a Chromebook, keep an eye out for our Best Chromebooks of 2021 video that will be dropping soon to see what we recommend in each category and for a variety of budgets. Chrome 48 was first announced back in 2016, so it’s had a great run, I think. Remember that anyone who continues to use outdated browser versions may end up saving money upfront, but ultimately, will be susceptible to malware targeting, so it’s not recommended to do so. Let me know in the comments if you’re running Chrome 48 or a version even older than that, and more importantly, I’d love to hear your reasoning behind doing so!



Original Source by [author_name]

Leave a Reply

Your email address will not be published. Required fields are marked *

eighty − seventy =