Cisco Patches Critical Vulnerability in Email Security Appliance | #emailsecurity | #phishing | #ransomware


Cisco on Wednesday announced patches for a critical vulnerability affecting its Email Security Appliance (ESA) and Secure Email and Web Manager products.

Tracked as CVE-2022-20798 (CVSS score of 9.8), the security bug can be exploited remotely to bypass authentication and log in to the web management interface of impacted appliances.

“This vulnerability is due to improper authentication checks when an affected device uses Lightweight Directory Access Protocol (LDAP) for external authentication. An attacker could exploit this vulnerability by entering a specific input on the login page of the affected device,” the company explains.

According to Cisco, both virtual and hardware appliances running a vulnerable Cisco AsyncOS software release are impacted, if external authentication is enabled and LDAP is employed as the authentication protocol.

Secure Email and Web Manager customers are advised to update to AsyncOS versions 13.0.0-277, 13.6.2-090, 13.8.1-090, 14.0.0-418, or 14.1.0-250. ESA customers should update to AsyncOS 14.0.1-033.

The tech giant also announced patches for a high-severity issue in ESA and Secure Email and Web Manager that could allow an attacker to retrieve information from an LDAP external authentication server connected to a vulnerable appliance.

Tracked as CVE-2022-20664 (CVSS score of 7.7), the issue exists because input is not properly sanitized when querying the external authentication server.

For Secure Email and Web Manager customers, the issue was resolved in AsyncOS versions 13.6.2-090 and 14.1.0-227. For ESA customers, AsyncOS version 14.0.1-020 addresses the bug.

[ READ: Cisco Says Critical Flaw in Older SMB Routers Will Remain Unpatched ]

Also on Wednesday, Cisco warned that it does not plan to address a critical-severity vulnerability in Small Business RV110W, RV130, RV130W, and RV215W routers.

Tracked as CVE-2022-20825 (CVSS score of 9.8) and described as insufficient user input validation of incoming HTTP packets, the security flaw could allow an unauthenticated attacker to execute code remotely or cause a denial-of-service (DoS) condition.

“An attacker could exploit this vulnerability by sending a crafted request to the web-based management interface. A successful exploit could allow the attacker to execute arbitrary commands on an affected device using root-level privileges,” Cisco says.

The issue affects the web-based management interface of the RV110W, RV130, RV130W, and RV215W routers, all of which have already reached end-of-life (EOL), meaning that Cisco is no longer offering support for them.

“Cisco has not released and will not release software updates to address the vulnerability,” Cisco notes in its advisory.

The tech giant says it is not aware of any of these vulnerabilities being exploited in attacks.

Related: Cisco Patches Critical VM Escape in NFV Infrastructure Software

Related: Cisco Patches Critical Vulnerabilities in Small Business RV Routers

Related: Cisco Patches 11 High-Severity Vulnerabilities in Security Products

Ionut Arghire is an international correspondent for SecurityWeek.

Previous Columns by Ionut Arghire:
Tags:



Original Source link

Leave a Reply

Your email address will not be published.

− two = 6