Attackers are scanning for vulnerable VMware servers, patch now! | #microsoft | #hacking | #cybersecurity


Threat actors are actively scanning for Internet-exposed VMware vCenter servers unpatched against a critical remote code execution (RCE) vulnerability impacting all vCenter deployments and patched by VMware ten days ago.

The ongoing scanning activity was spotted by threat intelligence company Bad Packets yesterday and confirmed earlier today by cybersecurity expert Kevin Beaumont.

Security researchers have also developed and published a proof-of-concept (PoC) RCE exploit code targeting this critical VMware vCenter bug tracked as CVE-2021-21985.

Thousands of vulnerable vCenter servers are reachable over the Internet at the moment, according to the Shodan search engine for Internet-connected devices.

VMware vCenter scanning - Bad Packets

Attackers have previously mass scanned for unpatched vCenter servers after security researchers published PoC exploit code for another critical RCE security flaw (CVE-2021-21972) also affecting all default vCenter installs.

Impacts all vCenter Server deployments

Unauthenticated attackers can remotely exploit the security flaw in low complexity attacks which don’t require user interaction.

Successful exploitation allows threat actors to take over an organization’s entire network, seeing that IT teams and admins use VMware vCenter servers to manage VMware solutions deployed across enterprise environments.

“The vSphere Client (HTML5) contains a remote code execution vulnerability due to lack of input validation in the Virtual SAN Health Check plug-in which is enabled by default in vCenter Server,” the company explains.

“Virtual SAN Health Check plug-in is enabled by default in all vCenter Server deployments, whether or not vSAN is being used.”

“These updates fix a critical security vulnerability, and it needs to be considered at once,” VMware warned after released security updates to address the bug tracked as CVE-2021-21985.

“This vulnerability can be used by anyone who can reach vCenter Server over the network to gain access, regardless of whether you use vSAN or not.”

Ransomware warning

VMware also warned customers to patch their systems immediately, hinting at the possibility of incoming ransomware attacks targeting unpatched and exposed Center servers.

To put things into perspective and highlight the importance of patching vulnerable vCenter servers as soon as possible, VMware’s warning should be taken seriously since similarly critical VMware security flaws have been exploited in the past to deploy ransomware enterprise networks.

Multiple ransomware gangs, including Darkside, RansomExx, and Babuk Locker have exploited VMWare ESXi pre-auth RCE bugs to encrypt virtual hard disks used as centralized enterprise storage space.

In this era of ransomware, it is safest to assume that an attacker is already inside the network somewhere, on a desktop, and perhaps even in control of a user account, which is why we strongly recommend declaring an emergency change and patching as soon as possible. — VMware

The company also provides workaround measures designed to remove the attack vector and possibility of exploitation by setting the impacted plug-ins to “incompatible” for those who cannot immediately apply the security updates.

Customers can also find baseline security best practices for vSphere in the vSphere Security Configuration Guide.

A detailed FAQ with additional questions and answers regarding this critical vulnerability is available here.





Original Source link

Leave a Reply

Your email address will not be published. Required fields are marked *

61 − = fifty six